Several monitoring locations experience difficulties with data collecting

Incident Report for 360 Monitoring

Resolved

This incident has been resolved.
Posted May 21, 2026 - 11:32 UTC

Identified

The issue has been identified, and we are working to fix it.
Posted May 21, 2026 - 08:42 UTC
This incident affected: Health check probes.